$re = '/^((0[1-9]|[12]\d|3[01])\/(0[3578]|1[02])\/((202[1-9])))$|^((0[1-9]|[12]\d|30)\/(0[469]|11)\/((202[1-9])))$|^((0[1-9]|[1]\d|(2[0-8]))\/(02)\/(202[2-9]))$|^((0[1-9]|[12]\d|3[01])\/(01)\/((202[2-9])))$|^((2[0-8])\/(02)\/(2021))$/m';
$str = '11/02/2022
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);