package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((0[1-9]|[12]\d|3[01])\/(0[3578]|1[02])\/((202[1-9])))$|^((0[1-9]|[12]\d|30)\/(0[469]|11)\/((202[1-9])))$|^((0[1-9]|[1]\d|(2[0-8]))\/(02)\/(202[2-9]))$|^((0[1-9]|[12]\d|3[01])\/(01)\/((202[2-9])))$|^((2[0-8])\/(02)\/(2021))$`)
var str = `11/02/2022
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}