import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((0[1-9]|[12]\\d|3[01])\\/(0[3578]|1[02])\\/((202[1-9])))$|^((0[1-9]|[12]\\d|30)\\/(0[469]|11)\\/((202[1-9])))$|^((0[1-9]|[1]\\d|(2[0-8]))\\/(02)\\/(202[2-9]))$|^((0[1-9]|[12]\\d|3[01])\\/(01)\\/((202[2-9])))$|^((2[0-8])\\/(02)\\/(2021))$";
final String string = "11/02/2022\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}