// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""value":"[a-zA-z\s.]+"#).unwrap();
let string = "\"{\"error\":{\"code\":\"/IWBEP/CM_MGW_RT/022\",\"message\":{\"lang\":\"en\",\"value\":\"Active Delegation already Exists.\"},\"innererror\":{\"transactionid\":\"5560F03E45262DE0E10080000A492395\",\"timestamp\":\"\",\"Error_Resolution\":{\"SAP_Transaction\":\"\",\"SAP_Note\":\"\"},\"errordetails\":[{\"code\":\"/IWBEP/CX_MGW_BUSI_EXCEPTION\",\"message\":\"Active Delegation already Exists\",\"propertyref\":\"\",\"severity\":\"error\",\"target\":\"\"}]}}}\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}