# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"value\":\"[a-zA-z\s.]+"
test_str = "\"{\"error\":{\"code\":\"/IWBEP/CM_MGW_RT/022\",\"message\":{\"lang\":\"en\",\"value\":\"Active Delegation already Exists.\"},\"innererror\":{\"transactionid\":\"5560F03E45262DE0E10080000A492395\",\"timestamp\":\"\",\"Error_Resolution\":{\"SAP_Transaction\":\"\",\"SAP_Note\":\"\"},\"errordetails\":[{\"code\":\"/IWBEP/CX_MGW_BUSI_EXCEPTION\",\"message\":\"Active Delegation already Exists\",\"propertyref\":\"\",\"severity\":\"error\",\"target\":\"\"}]}}}\""
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.