import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"value\":\"[a-zA-z\\s.]+";
final String string = "\"{\"error\":{\"code\":\"/IWBEP/CM_MGW_RT/022\",\"message\":{\"lang\":\"en\",\"value\":\"Active Delegation already Exists.\"},\"innererror\":{\"transactionid\":\"5560F03E45262DE0E10080000A492395\",\"timestamp\":\"\",\"Error_Resolution\":{\"SAP_Transaction\":\"\",\"SAP_Note\":\"\"},\"errordetails\":[{\"code\":\"/IWBEP/CX_MGW_BUSI_EXCEPTION\",\"message\":\"Active Delegation already Exists\",\"propertyref\":\"\",\"severity\":\"error\",\"target\":\"\"}]}}}\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}