// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)([\s\S]*?)[\s]*def (\w+)Impl\((.*)\):[\s]+"""[\s]+([\s\S]*?)[\s]+"""([\s\S]*?)((def|$)[\s\S]*)$"#).unwrap();
let string = "def TestUnParamImpl(param1):
\"\"\"
@param param1 string Param named param1
@return return1 string Return named return1
\"\"\"
\"\"\"
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d[\"param1\"]
# Your code here
ret_dict = {}
ret_dict[\"return1\"] = \"\"
return json.dumps(ret_dict)
\"\"\"
return {
\"return1\": \"string\"
}
def TestDeuxParamsImpl(paramString, paramInt):
\"\"\"
@param paramString string Param named paramString
@param paramInt integer Param named paramInt
@return returnString string Return named returnString
@return returnInt integer Return named returnInt
\"\"\"
\"\"\"
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d[\"paramString\"] d[\"paramInt\"]
# Your code here
ret_dict = {}
ret_dict[\"returnString\"] = \"\"
ret_dict[\"returnInt\"] = \"\"
return json.dumps(ret_dict)
\"\"\"
return {
\"returnString\": \"string\",
\"returnInt\": \"integer\"
}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}