use strict;
my $str = 'def TestUnParamImpl(param1):
"""
@param param1 string Param named param1
@return return1 string Return named return1
"""
"""
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d["param1"]
# Your code here
ret_dict = {}
ret_dict["return1"] = ""
return json.dumps(ret_dict)
"""
return {
"return1": "string"
}
def TestDeuxParamsImpl(paramString, paramInt):
"""
@param paramString string Param named paramString
@param paramInt integer Param named paramInt
@return returnString string Return named returnString
@return returnInt integer Return named returnInt
"""
"""
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d["paramString"] d["paramInt"]
# Your code here
ret_dict = {}
ret_dict["returnString"] = ""
ret_dict["returnInt"] = ""
return json.dumps(ret_dict)
"""
return {
"returnString": "string",
"returnInt": "integer"
}
';
my $regex = qr/([\s\S]*?)[\s]*def (\w+)Impl\((.*)\):[\s]+"""[\s]+([\s\S]*?)[\s]+"""([\s\S]*?)((def|$)[\s\S]*)$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}