const regex = /([\s\S]*?)[\s]*def (\w+)Impl\((.*)\):[\s]+"""[\s]+([\s\S]*?)[\s]+"""([\s\S]*?)((def|$)[\s\S]*)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S]*?)[\\s]*def (\\w+)Impl\\((.*)\\):[\\s]+"""[\\s]+([\\s\\S]*?)[\\s]+"""([\\s\\S]*?)((def|$)[\\s\\S]*)$', 'i')
const str = `def TestUnParamImpl(param1):
"""
@param param1 string Param named param1
@return return1 string Return named return1
"""
"""
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d["param1"]
# Your code here
ret_dict = {}
ret_dict["return1"] = ""
return json.dumps(ret_dict)
"""
return {
"return1": "string"
}
def TestDeuxParamsImpl(paramString, paramInt):
"""
@param paramString string Param named paramString
@param paramInt integer Param named paramInt
@return returnString string Return named returnString
@return returnInt integer Return named returnInt
"""
"""
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d["paramString"] d["paramInt"]
# Your code here
ret_dict = {}
ret_dict["returnString"] = ""
ret_dict["returnInt"] = ""
return json.dumps(ret_dict)
"""
return {
"returnString": "string",
"returnInt": "integer"
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}