package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\s\S]*?)[\s]*def (\w+)Impl\((.*)\):[\s]+"""[\s]+([\s\S]*?)[\s]+"""([\s\S]*?)((def|$)[\s\S]*)$`)
var str = `def TestUnParamImpl(param1):
"""
@param param1 string Param named param1
@return return1 string Return named return1
"""
"""
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d["param1"]
# Your code here
ret_dict = {}
ret_dict["return1"] = ""
return json.dumps(ret_dict)
"""
return {
"return1": "string"
}
def TestDeuxParamsImpl(paramString, paramInt):
"""
@param paramString string Param named paramString
@param paramInt integer Param named paramInt
@return returnString string Return named returnString
@return returnInt integer Return named returnInt
"""
"""
# Imported code :
import json
d = json.loads(jsonstr)
# To use the input params, simply use d["paramString"] d["paramInt"]
# Your code here
ret_dict = {}
ret_dict["returnString"] = ""
ret_dict["returnInt"] = ""
return json.dumps(ret_dict)
"""
return {
"returnString": "string",
"returnInt": "integer"
}
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}