# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\s\S]*?)[\s]*def (\w+)Impl\((.*)\):[\s]+\"\"\"[\s]+([\s\S]*?)[\s]+\"\"\"([\s\S]*?)((def|$)[\s\S]*)$"
test_str = ("def TestUnParamImpl(param1):\n"
" \"\"\"\n"
" @param param1 string Param named param1\n"
" @return return1 string Return named return1\n"
" \"\"\"\n"
" \n"
" \"\"\"\n"
" # Imported code :\n"
" \n"
" import json\n"
" d = json.loads(jsonstr)\n\n"
" # To use the input params, simply use d[\"param1\"] \n"
" # Your code here\n\n"
" ret_dict = {}\n"
" ret_dict[\"return1\"] = \"\"\n"
" return json.dumps(ret_dict)\n"
" \"\"\"\n"
" \n"
" return {\n"
" \"return1\": \"string\"\n"
" }\n\n"
"def TestDeuxParamsImpl(paramString, paramInt):\n"
" \"\"\"\n"
" @param paramString string Param named paramString\n"
" @param paramInt integer Param named paramInt\n"
" @return returnString string Return named returnString\n"
" @return returnInt integer Return named returnInt\n"
" \"\"\"\n"
" \n"
" \"\"\"\n"
" # Imported code :\n"
" \n"
" import json\n"
" d = json.loads(jsonstr)\n\n"
" # To use the input params, simply use d[\"paramString\"] d[\"paramInt\"] \n"
" # Your code here\n\n"
" ret_dict = {}\n"
" ret_dict[\"returnString\"] = \"\"\n"
" ret_dict[\"returnInt\"] = \"\"\n"
" return json.dumps(ret_dict)\n"
" \"\"\"\n"
" \n"
" return {\n"
" \"returnString\": \"string\",\n"
" \"returnInt\": \"integer\"\n"
" }\n"
" ")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.