import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\S]*?)[\\s]*def (\\w+)Impl\\((.*)\\):[\\s]+\"\"\"[\\s]+([\\s\\S]*?)[\\s]+\"\"\"([\\s\\S]*?)((def|$)[\\s\\S]*)$";
final String string = "def TestUnParamImpl(param1):\n"
+ " \"\"\"\n"
+ " @param param1 string Param named param1\n"
+ " @return return1 string Return named return1\n"
+ " \"\"\"\n"
+ " \n"
+ " \"\"\"\n"
+ " # Imported code :\n"
+ " \n"
+ " import json\n"
+ " d = json.loads(jsonstr)\n\n"
+ " # To use the input params, simply use d[\"param1\"] \n"
+ " # Your code here\n\n"
+ " ret_dict = {}\n"
+ " ret_dict[\"return1\"] = \"\"\n"
+ " return json.dumps(ret_dict)\n"
+ " \"\"\"\n"
+ " \n"
+ " return {\n"
+ " \"return1\": \"string\"\n"
+ " }\n\n"
+ "def TestDeuxParamsImpl(paramString, paramInt):\n"
+ " \"\"\"\n"
+ " @param paramString string Param named paramString\n"
+ " @param paramInt integer Param named paramInt\n"
+ " @return returnString string Return named returnString\n"
+ " @return returnInt integer Return named returnInt\n"
+ " \"\"\"\n"
+ " \n"
+ " \"\"\"\n"
+ " # Imported code :\n"
+ " \n"
+ " import json\n"
+ " d = json.loads(jsonstr)\n\n"
+ " # To use the input params, simply use d[\"paramString\"] d[\"paramInt\"] \n"
+ " # Your code here\n\n"
+ " ret_dict = {}\n"
+ " ret_dict[\"returnString\"] = \"\"\n"
+ " ret_dict[\"returnInt\"] = \"\"\n"
+ " return json.dumps(ret_dict)\n"
+ " \"\"\"\n"
+ " \n"
+ " return {\n"
+ " \"returnString\": \"string\",\n"
+ " \"returnInt\": \"integer\"\n"
+ " }\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}