import Foundation
let pattern = #"\[(.*?)\]\((\S*?) ?('(.*?)')?\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
[Descriptive text](https://example.com/ 'Title text')
[Descriptive text
Accepts linkebreak](https://example.com/ 'Title text
Accepts linkebreaks')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$2" title="$4">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)