# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(.*?)\]\((\S*?) ?('(.*?)')?\)/<a href="$2" title="$4">$1<\/a>/gs;t' <<< "[Descriptive text](https://example.com/ 'Title text')
[Descriptive text
Accepts linkebreak](https://example.com/ 'Title text
Accepts linkebreaks')"