package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[(.*?)\]\((\S*?) ?('(.*?)')?\)`)
var str = `[Descriptive text](https://example.com/ 'Title text')
[Descriptive text
Accepts linkebreak](https://example.com/ 'Title text
Accepts linkebreaks')`
var substitution = "<a href="$2" title="$4">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}