use strict;
my $str = '[Descriptive text](https://example.com/ \'Title text\')
[Descriptive text
Accepts linkebreak](https://example.com/ \'Title text
Accepts linkebreaks\')';
my $regex = qr/\[(.*?)\]\((\S*?) ?('(.*?)')?\)/sp;
my $subst = '<a href="$2" title="$4">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";