using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.*?)\]\((\S*?) ?('(.*?)')?\)";
string substitution = @"<a href=""$2"" title=""$4"">$1</a>";
string input = @"[Descriptive text](https://example.com/ 'Title text')
[Descriptive text
Accepts linkebreak](https://example.com/ 'Title text
Accepts linkebreaks')";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}