$re = '/\[(.*?)\]\((\S*?) ?(\'(.*?)\')?\)/s';
$str = '[Descriptive text](https://example.com/ \'Title text\')
[Descriptive text
Accepts linkebreak](https://example.com/ \'Title text
Accepts linkebreaks\')';
$subst = "<a href=\"$2\" title=\"$4\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;