import Foundation
let pattern = #"<(script)([^\/>]*?)>((\s|.)*?)<\/script\s?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<script type=3D"text/javascript">hsjQuery =3D window['jQuery']</script>
<script type=3D"textjavascript">hsjQuery = 1 / 2</script>
<script type=3D"text/javascript"/>hsjQuery = 1 / 2</script>
<script type="textjavascript">asdgsdgs</script>
<script />
<script>lala</script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<ff-$1 style='display: none;'$2>$3</ff-$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)