# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(script)([^\\/>]*?)>((\s|.)*?)<\\/script\s?>/<ff-$1 style='display: none;'$2>$3<\/ff-$1>/gim;t' <<< "<script type=3D\"text/javascript\">hsjQuery =3D window['jQuery']</script>
<script type=3D\"textjavascript\">hsjQuery = 1 / 2</script>
<script type=3D\"text/javascript\"/>hsjQuery = 1 / 2</script>
<script type=\"textjavascript\">asdgsdgs</script>
<script />
<script>lala</script>"