use strict;
my $str = '<script type=3D"text/javascript">hsjQuery =3D window[\'jQuery\']</script>
<script type=3D"textjavascript">hsjQuery = 1 / 2</script>
<script type=3D"text/javascript"/>hsjQuery = 1 / 2</script>
<script type="textjavascript">asdgsdgs</script>
<script />
<script>lala</script>';
my $regex = qr/<(script)([^\/>]*?)>((\s|.)*?)<\/script\s?>/imp;
my $subst = '<ff-$1 style=\'display: none;\'$2>$3</ff-$1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";