// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)<(script)([^\/>]*?)>((\s|.)*?)<\/script\s?>").unwrap();
let string = "<script type=3D\"text/javascript\">hsjQuery =3D window['jQuery']</script>
<script type=3D\"textjavascript\">hsjQuery = 1 / 2</script>
<script type=3D\"text/javascript\"/>hsjQuery = 1 / 2</script>
<script type=\"textjavascript\">asdgsdgs</script>
<script />
<script>lala</script>";
let substitution = "<ff-$1 style='display: none;'$2>$3</ff-$1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}