using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(script)([^\/>]*?)>((\s|.)*?)<\/script\s?>";
string substitution = @"<ff-$1 style='display: none;'$2>$3</ff-$1>";
string input = @"<script type=3D""text/javascript"">hsjQuery =3D window['jQuery']</script>
<script type=3D""textjavascript"">hsjQuery = 1 / 2</script>
<script type=3D""text/javascript""/>hsjQuery = 1 / 2</script>
<script type=""textjavascript"">asdgsdgs</script>
<script />
<script>lala</script>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}