import Foundation
let pattern = #"^(0*[1-9]\d{0,9}(\.\d{0,2})?0*|0*\.([1-9]|\d[1-9]|[1-9]\d)0*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
.0
.00
0.0
.
00016515464645
-1
-1.2
1..1
1.1.1
..1
..1.1
-
.-
-.16
111111111111111111
1.11111111
1.584646
00000.13
00000000014.15
1
1.2
0.2
.1
20
20.0
20.00
20.
1641616515
0001641616515
0165154646
20.00000000
0.1100000000000
1234567890.11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)