import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0*[1-9]\\d{0,9}(\\.\\d{0,2})?0*|0*\\.([1-9]|\\d[1-9]|[1-9]\\d)0*)$";
final String string = "0\n"
+ ".0\n"
+ ".00\n"
+ "0.0\n"
+ ".\n"
+ "00016515464645\n"
+ "-1\n"
+ "-1.2\n"
+ "1..1\n"
+ "1.1.1\n"
+ "..1\n"
+ "..1.1\n"
+ "-\n"
+ ".-\n"
+ "-.16\n"
+ "111111111111111111\n"
+ "1.11111111\n"
+ "1.584646\n\n"
+ "00000.13\n"
+ "00000000014.15\n"
+ "1\n"
+ "1.2\n"
+ "0.2\n"
+ ".1\n"
+ "20\n"
+ "20.0\n"
+ "20.00\n"
+ "20.\n"
+ "1641616515\n"
+ "0001641616515\n"
+ "0165154646\n"
+ "20.00000000\n"
+ "0.1100000000000\n"
+ "1234567890.11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}