package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0*[1-9]\d{0,9}(\.\d{0,2})?0*|0*\.([1-9]|\d[1-9]|[1-9]\d)0*)$`)
var str = `0
.0
.00
0.0
.
00016515464645
-1
-1.2
1..1
1.1.1
..1
..1.1
-
.-
-.16
111111111111111111
1.11111111
1.584646
00000.13
00000000014.15
1
1.2
0.2
.1
20
20.0
20.00
20.
1641616515
0001641616515
0165154646
20.00000000
0.1100000000000
1234567890.11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}