using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0*[1-9]\d{0,9}(\.\d{0,2})?0*|0*\.([1-9]|\d[1-9]|[1-9]\d)0*)$";
string input = @"0
.0
.00
0.0
.
00016515464645
-1
-1.2
1..1
1.1.1
..1
..1.1
-
.-
-.16
111111111111111111
1.11111111
1.584646
00000.13
00000000014.15
1
1.2
0.2
.1
20
20.0
20.00
20.
1641616515
0001641616515
0165154646
20.00000000
0.1100000000000
1234567890.11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}