# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0*[1-9]\d{0,9}(\.\d{0,2})?0*|0*\.([1-9]|\d[1-9]|[1-9]\d)0*)$"
test_str = ("0\n"
".0\n"
".00\n"
"0.0\n"
".\n"
"00016515464645\n"
"-1\n"
"-1.2\n"
"1..1\n"
"1.1.1\n"
"..1\n"
"..1.1\n"
"-\n"
".-\n"
"-.16\n"
"111111111111111111\n"
"1.11111111\n"
"1.584646\n\n"
"00000.13\n"
"00000000014.15\n"
"1\n"
"1.2\n"
"0.2\n"
".1\n"
"20\n"
"20.0\n"
"20.00\n"
"20.\n"
"1641616515\n"
"0001641616515\n"
"0165154646\n"
"20.00000000\n"
"0.1100000000000\n"
"1234567890.11")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.