#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0*[1-9]\d{0,9}(\.\d{0,2})?0*|0*\.([1-9]|\d[1-9]|[1-9]\d)0*)$"
Local $sString = "0" & @CRLF & _
".0" & @CRLF & _
".00" & @CRLF & _
"0.0" & @CRLF & _
"." & @CRLF & _
"00016515464645" & @CRLF & _
"-1" & @CRLF & _
"-1.2" & @CRLF & _
"1..1" & @CRLF & _
"1.1.1" & @CRLF & _
"..1" & @CRLF & _
"..1.1" & @CRLF & _
"-" & @CRLF & _
".-" & @CRLF & _
"-.16" & @CRLF & _
"111111111111111111" & @CRLF & _
"1.11111111" & @CRLF & _
"1.584646" & @CRLF & _
"" & @CRLF & _
"00000.13" & @CRLF & _
"00000000014.15" & @CRLF & _
"1" & @CRLF & _
"1.2" & @CRLF & _
"0.2" & @CRLF & _
".1" & @CRLF & _
"20" & @CRLF & _
"20.0" & @CRLF & _
"20.00" & @CRLF & _
"20." & @CRLF & _
"1641616515" & @CRLF & _
"0001641616515" & @CRLF & _
"0165154646" & @CRLF & _
"20.00000000" & @CRLF & _
"0.1100000000000" & @CRLF & _
"1234567890.11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")