re = /^[A-Z0-9]{18}[0-9]{2}$/m
str = 'AAAAAAAAAAAAAAAAAA11
AAAAAAAAAAAAAAAAAAA1
AAAAAAAAAAAAAAAAAA1A
ABCDEFGHIJ1234567890
ABCDEFGHIJ12345678901
12345678901234567890
123456789012345678901
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end