package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z0-9]{18}[0-9]{2}$`)
var str = `AAAAAAAAAAAAAAAAAA11
AAAAAAAAAAAAAAAAAAA1
AAAAAAAAAAAAAAAAAA1A
ABCDEFGHIJ1234567890
ABCDEFGHIJ12345678901
12345678901234567890
123456789012345678901
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}