#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z0-9]{18}[0-9]{2}$"
Local $sString = "AAAAAAAAAAAAAAAAAA11" & @CRLF & _
"AAAAAAAAAAAAAAAAAAA1" & @CRLF & _
"AAAAAAAAAAAAAAAAAA1A" & @CRLF & _
"ABCDEFGHIJ1234567890" & @CRLF & _
"ABCDEFGHIJ12345678901" & @CRLF & _
"12345678901234567890" & @CRLF & _
"123456789012345678901" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")