import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z0-9]{18}[0-9]{2}$";
final String string = "AAAAAAAAAAAAAAAAAA11\n"
+ "AAAAAAAAAAAAAAAAAAA1\n"
+ "AAAAAAAAAAAAAAAAAA1A\n"
+ "ABCDEFGHIJ1234567890\n"
+ "ABCDEFGHIJ12345678901\n"
+ "12345678901234567890\n"
+ "123456789012345678901\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}