using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z0-9]{18}[0-9]{2}$";
string input = @"AAAAAAAAAAAAAAAAAA11
AAAAAAAAAAAAAAAAAAA1
AAAAAAAAAAAAAAAAAA1A
ABCDEFGHIJ1234567890
ABCDEFGHIJ12345678901
12345678901234567890
123456789012345678901
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}