$re = '/^[A-Z0-9]{18}[0-9]{2}$/m';
$str = 'AAAAAAAAAAAAAAAAAA11
AAAAAAAAAAAAAAAAAAA1
AAAAAAAAAAAAAAAAAA1A
ABCDEFGHIJ1234567890
ABCDEFGHIJ12345678901
12345678901234567890
123456789012345678901
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);