// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^a-zA-Z\d]*)([a-zA-Z\d]*)").unwrap();
let string = "!@#1$%* ABC def:123
err1or one! a(t&(\\)Ct!0n
i select 4llsp&&&cial char!!?!???!?!
#tag";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}