$re = '/([^a-zA-Z\d]*)([a-zA-Z\d]*)/';
$str = '!@#1$%* ABC def:123
err1or one! a(t&(\\)Ct!0n
i select 4llsp&&&cial char!!?!???!?!
#tag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);