re = /([^a-zA-Z\d]*)([a-zA-Z\d]*)/
str = '!@#1$%* ABC def:123
err1or one! a(t&(\\)Ct!0n
i select 4llsp&&&cial char!!?!???!?!
#tag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end