const regex = /([^a-zA-Z\d]*)([a-zA-Z\d]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^a-zA-Z\\d]*)([a-zA-Z\\d]*)', 'g')
const str = `!@#1\$%* ABC def:123
err1or one! a(t&(\\)Ct!0n
i select 4llsp&&&cial char!!?!???!?!
#tag`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}