import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^a-zA-Z\\d]*)([a-zA-Z\\d]*)";
final String string = "!@#1$%* ABC def:123\n\n"
+ "err1or one! a(t&(\\)Ct!0n\n\n"
+ "i select 4llsp&&&cial char!!?!???!?!\n\n"
+ "#tag";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}