using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^a-zA-Z\d]*)([a-zA-Z\d]*)";
string input = @"!@#1$%* ABC def:123
err1or one! a(t&(\)Ct!0n
i select 4llsp&&&cial char!!?!???!?!
#tag";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}