import Foundation
let pattern = #"([A-Za-z-éèë]+) (\b[A-Z][A-ZÉ\s]+\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Marie-Noelle CHRAITI, Delphine PERRÉARD, Americo AGOSTINHO, Isabelle SOULAKE, Marlène FRACCARO HAMONEAU, Véronique CAMUS, Monique PEREZ, Henrique ALVES, Valérie SAUVAN, Claude GINET"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)