const regex = new RegExp('([A-Za-z-éèë]+) (\\b[A-Z][A-ZÉ\\s]+\\b)', 'gm')
const str = `Marie-Noelle CHRAITI, Delphine PERRÉARD, Americo AGOSTINHO, Isabelle SOULAKE, Marlène FRACCARO HAMONEAU, Véronique CAMUS, Monique PEREZ, Henrique ALVES, Valérie SAUVAN, Claude GINET`;
const subst = `$2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);