package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z-éèë]+) (\b[A-Z][A-ZÉ\s]+\b)`)
var str = `Marie-Noelle CHRAITI, Delphine PERRÉARD, Americo AGOSTINHO, Isabelle SOULAKE, Marlène FRACCARO HAMONEAU, Véronique CAMUS, Monique PEREZ, Henrique ALVES, Valérie SAUVAN, Claude GINET`
var substitution = "$2 $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}