use strict;
my $str = 'Marie-Noelle CHRAITI, Delphine PERRÉARD, Americo AGOSTINHO, Isabelle SOULAKE, Marlène FRACCARO HAMONEAU, Véronique CAMUS, Monique PEREZ, Henrique ALVES, Valérie SAUVAN, Claude GINET';
my $regex = qr/([A-Za-z-éèë]+) (\b[A-Z][A-ZÉ\s]+\b)/mp;
my $subst = '$2 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";