using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z-éèë]+) (\b[A-Z][A-ZÉ\s]+\b)";
string substitution = @"$2 $1";
string input = @"Marie-Noelle CHRAITI, Delphine PERRÉARD, Americo AGOSTINHO, Isabelle SOULAKE, Marlène FRACCARO HAMONEAU, Véronique CAMUS, Monique PEREZ, Henrique ALVES, Valérie SAUVAN, Claude GINET";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}