import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z-éèë]+) (\\b[A-Z][A-ZÉ\\s]+\\b)";
final String string = "Marie-Noelle CHRAITI, Delphine PERRÉARD, Americo AGOSTINHO, Isabelle SOULAKE, Marlène FRACCARO HAMONEAU, Véronique CAMUS, Monique PEREZ, Henrique ALVES, Valérie SAUVAN, Claude GINET";
final String subst = "$2 $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}