import Foundation
let pattern = ##"""
(?(DEFINE)
(?'loc_part' [\w!#$%&'*+\-\/=?^`{|}~]+ )
(?'loc' \g'loc_part' (?: \. \g'loc_part' )* )
(?'subdom' [a-z] (?: [a-z\d-]* [a-z\d] )? )
(?'tld' [a-z]{2,6} )
)
(?'local' \g'loc' ) @ (?'domain' (?: \g'subdom' \. )+ \g'tld' )
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
this is an email: this.is.an-example@example.com
how about a.b.c+194829@example.org?
not totallynotanemail@@exampl.e
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)