// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ix)(?(DEFINE)
(?'loc_part' [\w!#$%&'*+\-\/=?^`{|}~]+ )
(?'loc' \g'loc_part' (?: \. \g'loc_part' )* )
(?'subdom' [a-z] (?: [a-z\d-]* [a-z\d] )? )
(?'tld' [a-z]{2,6} )
)
(?'local' \g'loc' ) @ (?'domain' (?: \g'subdom' \. )+ \g'tld' )").unwrap();
let string = "this is an email: this.is.an-example@example.com
how about a.b.c+194829@example.org?
not totallynotanemail@@exampl.e
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}