const regex = /(?(DEFINE)
(?'loc_part' [\w!#$%&'*+\-\/=?^`{|}~]+ )
(?'loc' \g'loc_part' (?: \. \g'loc_part' )* )
(?'subdom' [a-z] (?: [a-z\d-]* [a-z\d] )? )
(?'tld' [a-z]{2,6} )
)
(?'local' \g'loc' ) @ (?'domain' (?: \g'subdom' \. )+ \g'tld' )/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?\'loc_part\' [\\w!#$%&\'*+\\-\\\/=?^`{|}~]+ )
(?\'loc\' \\g\'loc_part\' (?: \\. \\g\'loc_part\' )* )
(?\'subdom\' [a-z] (?: [a-z\\d-]* [a-z\\d] )? )
(?\'tld\' [a-z]{2,6} )
)
(?\'local\' \\g\'loc\' ) @ (?\'domain\' (?: \\g\'subdom\' \\. )+ \\g\'tld\' )', 'ig')
const str = `this is an email: this.is.an-example@example.com
how about a.b.c+194829@example.org?
not totallynotanemail@@exampl.e
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}